To use the E-Phonic MP3 Player you will need Adobe Flash Player 9 or better and a Javascript enabled browser.
[It takes some time to load, so be patient]

 

This player is based on Flash technology, so if you don't install it's application, you will not be able to see this player. Application is really small so it will take just a moment to download and install. Many internet pages use it too, so if you already don't have it installed, do it now... Just reload this page and you'll be asked to install it.